
이장에서는모바일웹개발환경에대해서배울것이다. 

모바일 웹 개발을 위해서 필요한 도구들은 전통적인 웹 개발 도구와 다르지 않다. 모

바일웹개발환경에필요한도구로는대표적으로서버측스크립트언어, 스크립트와

마크업을지원하는견고한 IDE, 환경에맞게설정할수있는웹서버, 그리고웹페이

지를 테스트하고 표시 방식을 확인할 수 있는 웹 브라우저 등이 있다. 또한 프로젝트

진행중변경내용을관리고추적할수있도록파일을비교하고소스코드를제어하는

도구를사용할것을권장한다.

모바일 웹 개발자로서 여러분은 개발 환경에 맞춰 새로운 도구 사용법을 배우고, 웹

서버나웹브라우저설정을수정하는데익숙해져야한다. IDE를사용해서모바일웹

개발 프로젝트를 시작하면 문법 요소마다 구별된 색을 제공하기 때문에 구문을 한눈

에파악할수있고, 모바일마크업언어자동완성기능을사용해서개발효율성을높

일 수 있다. 하지만 웹 서버가 모바일 MIME 유형을 지원하게 하려면 개발자가 직접

웹서버설정을확장해야만한다. 오픈소스브라우저인파이어폭스는매우유연한브

라우저여서설정을변경하면모바일디바이스로위장해모바일웹을데스크톱에서열

람할수있다. 또한개발자들은특정모바일브라우저나디바이스에특화된모바일웹

화면을좀더정확히보기위해모바일폰에뮬레이터를사용할수있다. 그리고콘텐

CHAPTER 2
모바일 웹 개발 환경

구축하기
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츠와 실제 디바이스 사이의 호환성을 테스트하기 위해 모바일 특화된 테스트 도구를

사용해야한다.

여러분은다음리스트에서소개하는세가지도구중하나를사용해다양한모바일상

황에서 웹 페이지를 볼 수 있다. 리스트는 테스트 검증 신뢰도가 낮은 도구부터 높은

도구순서로나열했다.

1. 모바일 부가 기능add-on을 사용한 파이어폭스는 브라우저를 모바일 디바이스들

로 위장해 모바일 웹 문서를 확인할 수 있다. 파이어폭스는 모바일 마크업을

테스트하는 편리한 개발자 도구지만 실제 모바일 디바이스의 표현 방식을 묘

사하기에는부족하다. 그래서이방법은개발자수준의테스트로만적합하다.

2. 모바일 브라우저 에뮬레이터는 실제 모바일 브라우저 코드를 실행시켜 문서 표

현방식을포함한 모든브라우저기능을 시뮬레이션한다. 이것은 실제모바일

브라우저의 행동방식과거의 비슷하다. 하지만 모든유형의모바일 디바이스

에대해해당디바이스의에뮬레이터를사용할수있는것은아니다.

3. 말할 것도 없이 실제 모바일 디바이스의 모바일 브라우저를 사용하는 것이 모바

일웹페이지의행동을테스트하기에는가장훌륭하다. 이테스트방법은모바

일 사용자와 웹 페이지 간의 상호작용을 확인할 수 있는 가장 정확한 방법이

다. 모바일웹페이지테스트에관한좀더자세한정보를얻고싶다면 11장을

참고하라.

추천 IDE

IDE는웹애플리케이션개발의전과정에서사용되는개발자도구로애플리케이션을

설계하고, 프로그래밍하고, 실행하고, 그리고디버깅하는소프트웨어이다.

모바일 웹 개발을 위한 IDE가 따로 정해져 있는 것은 아니다. IDE가 마크업 언어를

사용하는 웹 개발을 지원한다면 모바일 환경에서 사용하는 것이 가능하다. 여러분의

모바일웹프로젝트상황에맞게 IDE를선택할수있다. 선택은여러분의몫이다. 웹



개발에서요구하는언어에는웹문서를만들때사용하는마크업언어와서버측런타

임 언어뿐만 아니라 웹 문서의 스타일을 정의하는 CSS와 클라이언트 측과 상호작용

기능을구현하는자바스크립트파일도있다.

모든 IDE는문법요소에따라다른색상을제공하는기능, 그리고구문자동완성기

능을제공해야한다. 또한마크업과스크립트언어의구문에러를표시해야한다. CSS

에 대한 구문 에러 표시를 일부분 제공하고는 있지만 완전하지는 않다. IDE 중에는

다른 IDE에서설정한웹개발프로젝트환경을그대로옮겨오는 기능을제공하는 것

도 있다. IDE를 선택할 때는 개발 생산성을 고려해야 하며, 만약 기존 IDE의 사용성

에만족하지못한다면 IDE를바꾸는데주저하지말아야한다. 여러분은 IDE에서모

바일 웹 개발 프로젝트를 만드는 데 많은 시간을 쓸 것이다. 그렇기 때문에 효율적인

웹개발을지원하는 IDE를선택하는것은매우중요하다.

웹개발자들은보통 IDE를선택할때서버측런타임언어의지원여부를따진다. 마

크업언어지원은안정화된모든 IDE에서가능하다. 표 2-1은인지도가높은웹개발

IDE에 대한 개발 플랫폼과 지원하는 런타임 언어를 정리한 것이다. 표에서 소개한

IDE는모두 HTML, XHTML을지원한다. 그리고대부분의모바일마크업언어들에

대한최소한의지원을보장한다.

Adobe Dreamweaver와 같이 웹 디자인에 특화된 환경은 모바일 웹 페이지의 레이아

웃을 만드는 데는 도움이 되지만 레이아웃을 모바일 웹 애플리케이션으로 구현하는

런타임언어에대한지원은부족하다.

그림 2-1은이클립스 PHP 개발도구에서본 XHTML-MP 웹페이지를구현한 PHP

템플릿의스크린샷을보여준다. 그림 2-2는같은 PHP 템플릿을 NetBeans에서본모

습이다.
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∷ 표 2-1 유명한 웹 개발 IDE에 대한 플랫폼과 런타임 언어
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IDE 개발 플랫폼 웹 런타임 언어 라이선스 URL

Eclipse
Windows
Linux
Mac OS

C/C++
Java
PHP
Python

무료 오픈소스 http://eclipse.org

Microsoft
Visual 
Studio

Windows 

.NET
C#
C/C++
Python 
(requires 
add-on)
Ruby (requires
add-on)

상용
http://www.microsoft.

com/visualstudio/

Komodo 
Windows
Linux
Mac OS

Perl
PHP
Python
Ruby

상용
http://www.activestate.

com/komodo/

NetBeans

Windows
Linux
Mac OS
Solaris

C/C++
Groovy
Java
PHP
Python
Ruby

무료 오픈소스 http://netbeans.org

NuSphere
PhpED

Windows PHP 상용
http://www.nusphere.com

/products/phped.htm

Aptana 
Studio

Windows
Linux
Mac

PHP
Python
Ruby on Rails

이중 라이선스. 
무료 오픈소스
프로페셔널 버
전을 위한 상용

http://aptana.com/

studio

Zend Studio
Windows
Linux
Mac

PHP 상용
http://www.zend.com/en

/products/studio



∷ 그림 2-1 이클립스 PHP 개발 도구 3.3에서 본 XHTML-MP 1.1 마크업 문서

∷ 그림 2-2 NetBeans PHP 6.7에서 본 XHTML-MP 1.1 마크업 문서
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모바일 MIME 유형

모바일 MIME 유형(콘텐츠유형)은모바일웹콘텐츠형식을알아보는데사용한다. 모

바일 콘텐츠 종류는 매우 다양하다. 모바일 마크업을 포함하는 텍스트 문서 또는 볼

수있고플레이할수있는콘텐츠를포함하는, 예를들어휴대폰벨소리, 바탕화면, 비

디오같은바이너리파일들, 그리고실행가능한바이너리모바일애플리케이션등으

로 나눌 수 있다. HTTP 트랜잭션 중에 웹 서버와 브라우저 클라이언트는 MIME 유

형을사용해콘텐츠형식을구별한다.

모바일웹브라우저와웹서버사이에서HTTP 트랜잭션을실행하는동안몇가지방법

으로MIME 유형을사용한다(코드변환기또는프럭시에의해몇가지방법으로사용된다). 

■모바일 브라우저Mobile Browser: 모바일 브라우저는 Accept HTTP 요청 헤더 값을

지원되는 MIME 형식리스트로설정하여보낸다. Accept 요청헤더는해당모

바일 디바이스에서 지원되는 콘텐츠 유형을 알려준다. 불행하게도 어떤 모바

일 디바이스가 보내는 요청 헤더는 불확실한 정보를 포함하는 것으로 알려져

있다. 웹서버는이헤더값과모바일디바이스특성데이터베이스를고려하여

HTTP 응답에실어보낼가장적합한콘텐츠를결정한다.

■웹 서버Web Server: 웹 서버 설정 정보를 수정하여 모바일 MIME 유형과 모바일

콘텐츠의 파일 확장자를 연관시킬 수 있다(웹 서버들은 보통 모바일 MIME 유형

을지원하는설정이미리되어있다. 그러나웹마스터는반드시수동으로추가적인모

바일 MIME 유형을 추가해야 한다). 웹 문서와 연관된 MIME 유형은 HTTP 응

답에서 Content-Type 헤더의 값으로 사용된다. 웹 서버가 모바일 브라우저로

올바른모바일 MIME 유형을헤더에넣어파일과함께전송했다면모바일브

라우저는그파일을어떻게해석해야되는지알수있다. 파일은웹페이지, 모

바일 애플리케이션, 바탕화면, 휴대폰 벨소리,비디오 등이 될 수 있다(브라우

저가자체적으로파일을표시할수없는경우에는사용자에게파일을저장하거나설치

할수있는창을띄울것이다). 

■코드 변환기와 게이트웨이Transcoder and Gateway: 모바일 디바이스와 웹 서버 사이에

는종종코드를변환시키는 HTTP 프럭시서버가존재한다. 이프럭시서버들
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은 디바이스를 대신해서 원본 콘텐츠를 조작하는 방법을 결정하기 위해

Accept와 Content-Type 헤더를 조사할 수 있다. 예를 들어, PNG 이미지는

GIF 이미지로 코드가 변경될 수 있다. 또는 HTMP 문서는 XHTML로 변

환될수있다.

■서버 측 런타임 언어Server-Side Runtime language: 문서와연관된 MIME 유형을서버측

런타임언어를이용해오버라이드할수있다. 리스트 2-1은 XHTML-MP 문

서를포함한 HTTP 응답의 MIME 유형을설정하기위해스크립트의첫부분

에서내장함수를사용하는간단한 PHP 코드를보여준다.

<?php

header(’Content-Type: application/vnd.wap.xhtml+xml’);

?>

웹서버의모바일 MIME 유형설정은웹콘텐츠에대한모바일접근성측면에서중요

하다. 모바일브라우저는 HTTP 응답의 MIME 유형을사용해웹문서가해당브라우

저에서보일수있는지, 혹은모바일 OS 컴포넌트나네이티브모바일애플리케이션을

실행시켜보여줄수있는지를판단한다.

표 2-2는모바일웹에서일반적으로사용되는몇가지파일유형에대한 MIME 유형

리스트이다.

∷ 표 2-2 일반적으로 사용하는 모바일 파일 종류와 관련된 MIME 유형
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PHP를 사용하여 HTTP 응답의 MIME 유형 설정리스트 2-1

MIME 유형 파일 확장자 콘텐츠 사용

application/vnd.wap.xhtml+xml

application/xhtml+xml
xhtml

XHTML-MP 
markup

모바일 웹 페이지

text/html 

html(윈도우
서버에서는
htm)

HTML markup 

HTML을 지원하는 스
마트폰과 모바일 디바
이스용 모바일 웹 페
이지

text/css css
CSS1, CSS2, 
그리고
무선 CSS

모바일 웹 문서에서
캐스케이딩 스타일시
트



웹 서버 설정

모바일마크업과모바일문서파일확장자는 MIME 유형과연관된다. 모바일웹콘텐

츠를 호스팅하는 웹 서버는 설정된 내용을 바탕으로 모바일 파일 확장자와 연관된

MIME 유형을정확히결정한다. 웹서버에새로운 MIME 유형을추가하는설정은웹

서버모델마다다르다.
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application/javascript

text/javascript
js JavaScript 

HTML, XHTL-MP 1.1,
그리고 1.2와 함께 사
용되는 스크립트 언어

multipart/mixed -
MIME 
멀티파트 인코딩
문서

단일 HTTP 응답으로
마크업과 이와 관련된
자원들(이미지, CSS,
스크립트 등)을 다운
로드하는 것을 허용함

text/vnd.wap.wml wml WML markup 

성능이 낮은 구식 모
바일 디바이스를 위한
가벼운 모바일 웹 페
이지

text/vnd.wap.wmlscript wmls WML Script 
WML과 함께 사용되
는 스크립트 언어

audio/mp3

audio/mpeg
mp3 MP3 audio 벨소리와 음악 전체

audio/x-midi midi MIDI audio 벨소리

image/gif gif GIF image 바탕화면

image/jpg

image/jpeg

jpg
jpeg

JPG image 바탕화면

image/png png PNG image 바탕화면

video/3gpp 3gp 3GP video 모바일 비디오

video/mp4 mp4 MPEG4 video 모바일 비디오



아파치

아파치Apache 웹 서버는 mode_mime 설정에서 AddType 지시어를 사용해서 새로운

MIME 유형을 mime.types, httpd.conf, 또는 .htaccess 설정파일에추가한다. 

아파치의 mime.types과 httpd.conf 설정 파일은 전역 웹 서버 설정 파일이다. 이 파일

들은아파치웹서버의전체행동을제어한다.

아파치는 .htaccess 파일을 로컬 또는 디렉토리에 특화된 설정을 위해 사용한다.

.htaccess 파일의 설정 내용은 그것이 위치한 디렉토리(모든 하위 디렉토리를 포함하여)

범위에 영향을 준다. 아파치 프로젝트(http://httpd.apache.org)는 전역 아파치 설정

파일에 접근이 제한됐을 때만 .htaccess 파일을 사용할 것을 권장한다(예를 들어, 사용

자가자신의웹문서에대한제어권한만을가지고있고전체아파치서버에대한권한이없는

공유웹호스팅환경에서 .htaccess를사용할것을추천한다). 하지만 .htaccess 파일사용

을남용하면서버성능에영향을줄수있다.

AddType 설정지시어는다음과같은구문을사용해새로운모바일 MIME 유형과연관

된파일확장자리스트를명시한다.

AddType <MIME type> <file extension> [<file extension>] ...

리스트 2-2는새로운모바일 MIME 유형지원을추가하는 .htaccess 설정파일을보

여준다. 이파일은 .xhtml과 .xhtm 파일확장자를 XHTML-MP 마크업에대한 MIME

유형과 연관시킨다. 비슷하게, .wml파일 확장자는 WML 마크업에 대한 MIME 유형

과 연결됐다. 반면, .wmls 파일 확장자는 WML 스크립트에 대한 MIME 유형과 짝지

어졌다.

# XHTML-MP, WML, 그리고 WML 스크립트 파일 확장자를 위한 모바일 MIME 유형 추가
AddType application/vnd.wap.xhtml+xml .xhtml .xhtm

AddType text/vnd.wap.wml .wml

AddType text/vnd.wap.wmlscript .wmls
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모바일 MIME 유형에 대한 아파치 .htaccess 설정리스트 2-2



Microsoft IIS

Microsoft IIS Internet Information Services 웹서버는파일확장자와 MIME 유형연결을관리할

수있도록사용자인터페이스, 커맨드라인,그리고프로그래밍적메소드를제공한다.

MIME 유형 설정을 위해 IIS 관리 애플리케이션을 사용하는 것과 더불어 IIS 7은

MIME 유형 관리를 위한 커맨드라인 구문을 소개한다. 리스트 2-3은 XHTML-MP

마크업을 포함하는 .xhtml 파일을“application/vnd.wap.xhtml+xml”MIME 유형에 연

관시키는명령어를보여준다.

appcmd set config /section:staticContent ^

/+"[fileExtension='.xhtml',mimeType='application/vnd.wap.xhtml+xml']"

다음링크는 Microsoft TechNet에올라온글이다. IIS 관리애플리케이션또는스크립

트를이용한 MIME 유형관리에대한좀더자세한정보를제공한다.

■ IIS 4와 5: http://technet.microsoft.com/en-us/library/bb742440.aspx

■ IIS 6: www.microsoft.com/technet/prodtechnol/WindowsServer2003/Library/

IIS/cd72c0dc-c5b8-42e4-96c2–b3c656f99ead.mspx?mfr=true

■ IIS 7: http://technet.microsoft.com/en-us/library/cc725608(WS.10).aspx

Nginx

Nginx(http://nginx.net/)는정적파일을제공하는데매우적합할뿐아니라가벼운웹

서버이다. 사용자가많은사이트환경에서는일반적으로정적페이지를처리하는 nginx

뒤에서동적페이지생성작업을위임받아지원하는아파치또는 IIS 서버를사용한다.

Nginx는이미지,스타일시트, 그리고리소스요구가없는정적파일들을다룬다.

여러분은 types지시어를사용해 nginx.conf에서 MIME 유형을설정할수있다. 리스

트 2-4는 .xhtml 파일 확장자를 XHTML-MP 마크업 MIME 유형과 연관시키고,

.wml 파일확장자를 WML 마크업 MIME 유형과연결하는명령어예제를보여준다.
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커맨드라인에서 Microsoft IIS 7로 MIME 유형 추가리스트 2-3



types {

application/vnd.wap.xhtml+xml    xhtml;

text/vnd.wap.wml    wml;

}

데스크톱에서 모바일 웹 브라우저

모바일웹개발환경은모바일환경에서웹페이지를열람하는것으로위장하는도구

를 갖춰야 완성된다. 모바일 웹 페이지를 보기 위한 가장 편리한 개발자 도구는 파이

어폭스이다. 파이어폭스는특정모바일디바이스로위장하는설정방법이있고, 모바

일디바이스에서웹콘텐츠가표현되는방식과비슷하게제공해준다. 모바일디바이

스에뮬레이터는모바일디바이스와브라우저를대신할수있는데스크톱소프트웨어

이다. 여러분은실제모바일디바이스행동방식에좀더가까이다가갈수있다. 에뮬

레이터는 모바일 디바이스에서 사용하는 것과 같은 브라우저 엔진을 사용한다. 그러

나같은실행환경에서수행되는것이아니기때문에클라이언트측성능문제를추적

할때는이접근방식을사용할수없다. 모바일환경에서웹페이지를보는가장정확

한방법은실제모바일디바이스를사용하는것이다. 실제모바일을사용해야네트워

크지연과프럭시효과를볼수있기때문이다. 
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Nginx에 MIME 유형 추가하기리스트 2-4

Note 만약 여러분이 아이폰, 안드로이드 또는 노키아 Series 60 3rd Edition 또는 그 이후
버전 모바일 디바이스에 우선순위를 둔 모바일 웹 콘텐츠를 개발해야 한다면, 여러분은 애플 사파
리 (http://apple.com/safari/)  또는 구글 크롬(http://google.com/chrome)과 같은 WebKit 브라
우저를 사용한 테스트가 필요하다. 이 모바일 디바이스는 WebKit 기반 브라우저를 사용한다. 사파
리와 크롬이 이에 속하는 브라우저이다. WebKit 기반 브라우저는 user-agent 수정을 허용하고
코드 점검 도구를 제공한다.



파이어폭스와 모바일 부가 기능

파이어폭스는 모질라 협회의 표준 준수, 오픈소스 웹 브라우저이다. 특히 파이어폭스

는사용자가쉽게부가기능을사용해서환경에맞게브라우저기능을확장할수있다.

파이어폭스부가기능은 XULXML User Interface Language(https://developer.mozilla.org/en/XUL)

프로그래밍 언어로 개발된 확장 모듈이다. 모질라는 부가 기능 디렉토리를 https://

addons.mozilla.org/에서호스팅하고있다.

프로그래밍언어 XUL은애플리케이션로직을구현하는사용자인터페이스와자바스

크립트를 정의하기 위해 XML을 사용했다. XUL의 구호는“data는 이제 없다. 오직

XUL이있을뿐이다”이다. 

이 이야기로 더 관심이 생겼다면, XUL 문서에서 사용한 XML 네임스페이스를 리스

트 2-5에서확인해보자. 개발자들의유머감각도꽤쓸만한수준인것같다.

http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul

다음단계는파이어폭스가모바일디바이스로위장해서모바일마크업언어로작성된

웹 문서를 표시하는 데 필요한 몇 가지 부가 기능들을 다운받아서 설치하는 것이다.

http://www.mozilla.com/en-US/products/firefox/에서최신파이어폭스버전을다운받

는것으로시작하자. 다음에이어지는절에서는부가기능을어떻게설치하고사용하

는지설명할것이다. 모든부가기능을설치한후실행시키기위해서는파이어폭스를

재실행한다.
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Note 여러분 중에 궁금해할 사람들을 위해서 짧게 언급하자면, XUL 용어는 zool로 발음된다.
사실 XUL은 고전 괴짜 영화, 『Ghostbusters』에서 등장하는 신인 Zuul에 빗대어 묘사된다. 그 영
화에서 시고니 위버Signourney Weaver가 맡은 역할은 Zuul에게 영혼을 잡아먹힌 후 아주 유명한 대사를
한다. “Dana는 이제 없다. 오직 Zuul이 있을 뿐이다”

파이어폭스 확장 모듈에서 사용한 XML 기반 XUL 프로그래밍 언어에서 네임스페이스 URI리스트 2-5



확장 모듈을 설치하고 파이어폭스를 재실행한 후에 파이어폭스에서 Tools → Add-

ons 대화 상자를 연다. 그림 2-3은 몇 가지 확장 모듈이 설치된 부가 기능 대화 상자

를보여준다.

∷ 그림 2-3 모바일 부가 기능이 설치된 파이어폭스 3.0.11에서 Add-ons 대화 상자

XHTML Mobile Profile

XHTML Mobile Profile 부가 기능은 application/vnd.wap.xhtml+xml MIME 유형 지

원을돕는다. 이부가기능으로파이어폭스는 XHTML-MP 모바일웹문서를브라우

저 창에서 표시할 수 있다. 이 확장 모듈이 없는 파이어폭스는 XHTML-MP 문서를

파일로저장하도록사용자에게창을띄운다.

XHTML Mobile Profile 부가기능버전 0.5.3은 multipart/mixed MIME 유형에대한

지원도 추가했다. 멀티파트 인코딩은 모바일 마크업에 최적화된 마크업 문서와 의존
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리소스(이미지, CSS 스크립트등등)를단일 HTTP 응답하나로묶어전송할수있게한

다. 상당수의모바일브라우저와사업자들이모바일웹콘텐츠를위해멀티파트multipart

인코딩을 지원하다. 이 부가 기능은 멀티파트 인코딩된 HTML 컴포넌트를 브라우저

가표시할수있게한다. 멀티파트인코딩에대한좀더자세한정보는 9장을참고하라.

파이어폭스에서 https://addons.mozilla.org/en-US/firefox/addon/1345 사이트를열람

한후 Add to Firefox 버튼을클릭하면 XHTML Mobile Profile을설치할수있다. 이

부가 기능은 옵션이나 설정이 따로 필요 없다. 기능을 활성화시키면 브라우저에서

XHTML-MP와멀티파트인코딩된모바일마크업을볼수있다.

wmlbrowser

wmlbrowser 부가 기능은 파이어폭스가 WML 문서를 브라우저에서 표시하는 것을

허용한다. 이 부가 기능의 WML 렌더링은 WML 코드로 웹 문서를 개발하고 디버깅

하는 데 적합하고, 실제 모바일 디바이스 수준으로 WML 문서의 레이아웃을 비슷하

게 볼 수 있다. 하지만 여전히 에뮬레이터나 실제 모바일 디바이스에서 테스트해 볼

필요가있다. WML에대해서는 3장에서더자세히배울것이다.

이확장모듈이없는파이어폭스는사용자에게 WML 문서를파일로저장하도록창을

띄울것이다. 

파이어폭스에서 https://addons.mozilla.org/en-US/firefox/addon/62를 통해 부가 기

능을설치할수있다.

이부가기능은추가적인옵션이나설정이필요하지않다. 이기능을활성화시키면브

라우저창에서 WML 모바일마크업을볼수있다. 여러분은 wmlbrowser를사용해서

샘플 WML 문서 스크린 샷을 http://learnto.mobi/02/wml-var.wml에서 볼 수 있다(그

림 2-4).
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∷ 그림 2-4 wmlbrowser 부가 기능을 설치한 파이어폭스 3.0.11에서 본 카드 두 장을 구현한 WML
문서

User Agent Switcher

User Agent Switcher 부가기능은파이어폭스가 user-agent 값을변경하는것을가능

하게한다. user-agent 값은 HTTP 트랜잭션중에웹서버가브라우저를식별하는데

사용된다. 이 부가 기능은 사용자가 미리 정의한 user-agent 중 하나로 User-Agent

HTTP 요청헤더의값을설정한다. 모바일웹개발자들이 User Agent Switcher를이

용해 모바일 디바이스를 나타내는 user-agent 값으로 변경하게 된다. 웹사이트는

User-Agent 요청 헤더를 사용해 모바일 디바이스를 식별한 후 디바이스에 따라 맞춤

콘텐츠를 제공한다. 파이어폭스에서 모바일 디바이스로 위장하는 첫 번째 단계는 웹

요청을보낼때특정모바일로인식되는 user-agent를전송하는것이다. 

이확장모듈이없는파이어폭스는항상 HTTP 요청에디폴트 user-agent를보낸다.

파이어폭스에서 https://addons.mozilla.org/en-US/firefox/addon/526를 열람하면

User Agent Switcher를설치할수있다.

이 부가 기능은 사용자가 많은 모바일 디바이스에 대한 user-agent를 저장할 수 있도

록 했다. 사용자는 부가 기능을 활성화한 후 Tools → Default User Agent 메뉴에서
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쉽게 User-Agent HTTP 요청헤더값을변경할수있다.

그림 2-5는 User Agent Switcher의옵션대화상자스크린샷이다.

∷ 그림 2-5 User Agent Switcher의 옵션 대화 상자

옵션대화상자는 Tools → Default User-Agent → Edit User-Agent 메뉴항목을선

택하면볼수있다. 이대화상자는설치된 user-agent 리스트를수정하고볼수있도

록한다. 모바일디바이스들에대한샘플 user-agent에대해서는부록 A를참고하자.

또는 모바일 개발자 커뮤니티 mobiFoarge(http://mobiforge.com)에서 User Agent

Switcher를위해모바일 user-agent를모아패키지집합으로제공한다. 블로그포스트

http://mobiforge.com/ developing/blog/user-agent-switcher-config-file에서 첨부파

일로받아볼수있다.

그림 2-6은 User Agent Switcher에설치한 user-agent 리스트에서하나를선택한모

습이다.
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∷ 그림 2-6 파이어폭스 3.0.11의 Tools 메뉴를 사용해 user-agent 값 선택

User-Agent 요청헤더값을추가된값으로변경하려면 Tools메뉴를사용하라.

Modify Headers

Modify Headers 부가 기능은 파이어폭스에서 보낸 HTTP 요청 헤더를 미리 정의한

규칙을사용해수정하는것을허용한다. 모바일웹개발자들은이확장모듈을사용해

파이어폭스의요청헤더를모바일디바이스가보내는것과정확하게일치하도록수정

하는 데 사용한다. 파이어폭스에서 모바일 디바이스로 위장하기 위한 두 번째 단계는

웹요청을보낼때모바일이보내는HTTP 요청헤더집합과일치하게보내는것이다.

Modify Headers를 사용해 User-Agent 요청 헤더까지 수정하는 것도 가능하다. 하지

만, User-Agent 헤더를수정할때는좀더견고하고안정된지원이가능한 User Agent

Switcher 부가기능을사용할것을권장한다.

이확장모듈이없는파이어폭스는디폴트 HTTP 요청헤더집합을웹서버로전송할

것이다.

Modify Headers는파이어폭스에서 https://addons.mozilla.org/en-US/firefox/addon/967

을통해설치할수있다.
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그림 2-7은파이어폭스도구메뉴에서 Modify Headers 메뉴항목을보여준다.

∷ 그림 2-7 Modify Headers 대화 상자는 파이어폭스 3.0.11의 Tools 메뉴에서 사용할 수 있다

Modify Headers 부가 기능은 파이어폭스에서 보내는 HTTP 요청 헤더를 변경하는

간단한 규칙을 정의하기 위해 대화 상자를 이용한다. 각 규칙은 각각 하나의 요청 헤

더를더하고수정하고또는숨기는작업을한다. 규칙들은순차적으로실행되고, 개별

적으로활성화시키거나숨겨질수있다.

그림 2-8의예제규칙들은파이어폭스의요청헤더몇개를변경시킨다.

∷ 그림 2-8 샘플 규칙 정의를 위한 Modify Headers 대화 상자
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■ MSISDN: 5035551212을추가한다.

■ Via 헤더를 Via: 127.0.0.1로수정한다.

■ Connection 헤더를 Connection: close로수정한다.

■ Keep-Alive 헤더를제거한다.

규칙중두번째 MSISDN 규칙은비활성처리됐기때문에수행되지않는다. 

추가적인 조작이 필요 없이 Modify Headers 대화 상자가 열려 있기만 하면 Modify

Headers는파이어폭스요청헤더를변경한다. Configuration버튼을클릭하면설정을

변경할수있다.

파이어폭스의 요청 헤더를 직접 보면서 모바일 디바이스로 위장하기 위한 헤더 수정

규칙을 작성하는 것이 도움이 될 수 있다. Live HTTP Headers 부가 기능은 HTTP

요청/응답 헤더를 파이어폭스 창에서 보여준다. 또는 파이어폭스에서 http://

learnto.mobi/view.php를열람하여요청헤더를볼수있다.

모바일디바이스의샘플 HTTP 요청헤더에대해서는부록 B를참고하도록하자.

Live HTTP Headers

Live HTTP Headers 부가 기능을 사용해 사용자는 요청/응답 헤더를 볼 수 있다. 모

바일 웹 개발자들은 HTTP 헤더를 다시 검사해 파이어폭스가 모바일 디바이스로 완

전히위장했는지검사할수있다. 또한이과정을통해 HTTP 트랜잭션을더깊이이

해할수있다.

이 확장 모듈이 없는 파이어폭스는 Tools → Page Info 대화 상자에서 요약된 헤더의

정보만을확인할수있다.

Live HTTP는 https://addons.mozilla.org/en-US/firefox/addon/3829에서 설치할 수

있다.

그림 2-9는파이어폭스도구메뉴의 Live HTTP Headers 메뉴항목을보여준다.
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∷ 그림 2-9 파이어폭스의 Tools 메뉴에서 볼 수 있는 Live HTTP Headers 대화 상자

그리고대화상자를열기위해서 Tools → Live HTTP Headers 메뉴항목을선택하라

(그림 2-10).

∷ 그림 2-10 헤더를 보여주고 부가 기능 설정을 위한 Live HTTP Headers 대화 상자
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Live HTTP Headers 대화 상자는 실시간으로 HTTP 요청/응답 스트림을 보여준다.

헤더 수집을 멈추기 위해서는 Capture 체크박스를 해제하면 된다. 설정 내용을 변경

하기위해서는 Config 탭을사용하자.환경설정으로개발자들은어떤헤더를보여주

고저장할것인지에대해웹콘텐츠를필터filter할수있다. 

이 부가 기능은 파이어폭스의 Page Info 대화 상자에 웹 문서의 요청/응답 헤더를 보

여주는화면한장pane을추가했다.

∷ 그림 2-11 파이어폭스의 Page Info 대화 상자에 헤더 정보를 보여주는 Live HTTP Headers

Small Screen Renderer

Small Screen Renderer 부가기능은모바일디바이스화면처럼작은크기의웹페이지

를 표시할 화면을 만든다. 이 부가 기능은 웹 페이지가 모바일 디바이스의 작은 화면
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에서 어떻게 표현될지 미리 확인하기 위해 설계됐다. 모바일 웹 개발자는 이 부가 기

능을사용해서그들의페이지레이아웃이작은화면에적합한지어느정도확신을가

질수있다. 하지만에뮬레이터나실제모바일디바이스에서테스트하는것이훨씬정

확히페이지표시결과를얻을수있는방법이다.

이 확장 모듈이 없는 파이어폭스는 웹 페이지를 브라우저 창 전체에 맞춰 보여준다.

Small Screen Renderer는 https://addons.mozilla.org/en-US/firefox/addon/526에서

설치할수있다.

이부가기능은추가적으로필요한옵션이나설정할내용이없다. 기능이활성화되면

파이어폭스의 View 메뉴에서작은화면을껐다켰다할수있다. 

파이어폭스에서 View → Small Screen Rendering을선택해서웹페이지를작은화면

에표시하거나아니면원래화면에표시할수있다(그림 2-12).

∷ 그림 2-12 파이어폭스의 View 메뉴에서 Small Screen Rendering 토글링

Small Screen Rendering 부가 기능을 사용해 웹 페이지를 모바일 디바이스에서 어떻

게 보이는지 확인할 수 있다. 예를 들어, 그림 2-13은 CNN의 데스크톱 웹사이트를

파이어폭스의작은화면에서본것이다.

39CHAPTER 02 모바일 웹 개발 환경 구축하기



∷ 그림 2-13 파이어폭스에서 Small Screen Rendering으로 본 www.cnn.com

Firebug

Firebug 부가 기능은 어떤 웹 페이지에서든지 HTML, CSS, 그리고 자바스크립트를

편집하고 디버깅할 수 있게 해준다. Firebug는 웹사이트 성능 향상을 위한 검사와

DOM 검사를지원한다. 모바일웹개발자들은마크업과스타일구문에대한재검사,

에러검출, 클라이언트측스크립트디버그, 성능개선을위해 Firebug를사용한다.

이확장모듈이없는파이어폭스는브라우저창에서보이는웹콘텐츠를편집하지못

한다. 다른확장모듈은자바스크립트디버깅, DOM 검사, 그리고성능지표등각각

의 기능을 개별적으로 제공하긴 하지만 Firebug처럼 다양한 기능을 통합해서 제공하

지는않는다. Firebug는여러웹개발도구들이가지고있는중요한기능들을단일확
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장모듈로통합해서제공할뿐아니라파이어폭스브라우저에깨끗하게결합할수있

어사용이용이하다.

Firebug는파이어폭스의 https://addons.mozilla.org/en-US/firefox/addon/1843에서설치

할수있다. 또는Firebug 웹사이트 http://getfirebug.com/을방문해서설치할수있다.

이 부가 기능은 검사할 웹 콘텐츠의 유형과 웹 페이지를 제어하는 옵션을 가지고 있

다. 그림 2-14는파이어폭스의 Tools → Firebug 메뉴를보여준다.

∷ 그림 2-14 파이어폭스의 Tools → Firebug 메뉴

Firebug를사용하려면 F12를누르거나, Tools → Firebug → Open Firebug 메뉴항목

을 사용해라. 그림 2-15는 데스크톱 웹 페이지의 HTML과 CSS를 보여주는 Firebug

모습이다. 그화면에서페이지마크업의편집까지가능하다.

∷ 그림 2-15 HTML과 CSS의 구문을 확인하고 편집할 수 있는 Firebug 인터페이스
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모바일 브라우저 에뮬레이터

모바일 디바이스 OEM과 소프트웨어 사업자들은 모바일 디바이스와 브라우저에 대

한 에뮬레이터 제품을 제공한다. 개발자들은 이 에뮬레이터를 사용해 모바일 애플리

케이션을 실행하거나 모바일 웹을 열람하도록 시뮬레이션한다. 모바일 웹 개발자는

모바일에뮬레이터를가지고모바일디바이스에서웹페이지가어떻게표시되는지대

체로 정확하게 파악할 수 있고, 그 정보를 바탕으로 디버깅이 가능하다. 하지만 역시

가장 훌륭한 디버깅 방법은 실제 모바일 디바이스에서 모바일 웹 애플리케이션을 테스트하

는것이다.

모바일웹개발과정에서사용되는세가지유형의모바일에뮬레이터가있다.

■모바일 디바이스 에뮬레이터Mobile device emulator는모바일폰 OS와모바일애플리케

이션을 실행했을 때 모바일 디바이스가 어떻게 동작하는지 시뮬레이션한다.

개발자들은네이티브기능에접근하고, 모바일브라우저를사용하고, 또한외

부 애플리케이션을 실행하고 디버깅할 수 있다. 모바일 디바이스 OEM 측은

디바이스에뮬레이터를모바일개발자커뮤니티에무료로제공하고있다.

■모바일 브라우저 에뮬레이터Mobile browser emulator는오직모바일브라우저애플리케

이션만을 시뮬레이션 한다. 이 에뮬레이터는 모바일 디바이스에서 동작하는

것과 같은 애플리케이션을 사용해 사용자에게 웹 페이지 표시 결과를 보여준

다. 브라우저 사업자들은 브라우저 에뮬레이터를 모바일 개발자 커뮤니티에

무료로제공하고있다.

■모바일 기반 시설 에뮬레이터Mobile infrastructure emulator는 모바일 디바이스와 모바일

에코시스템에서 의존관계에 있는 서비스를 시뮬레이션한다. RIM이 생산한

블랙베리Blackberry 스마트폰은 이메일과 인터넷 접근을 관리하기 위해 기업 서

버와통신한다. RIM은모바일개발자가블랙베리사용환경을처음부터끝까

지 테스트할 수 있도록 블랙베리 디바이스와 기업 서비스를 시뮬레이션하는

에뮬레이터를제공한다.
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모바일 웹 개발자들은 그들의 웹 페이지가 다양한 종류의 모바일 디바이스와 브라우

저에서 각각 어떻게 표시되는지 분석하기 위해 여러 가지 모바일 에뮬레이터를 사용

하게될것이다. 그림 2-16~22는 CNN 모바일웹사이트가각각의모바일에뮬레이

터에서표시되는모습이다.

∷ 그림 2-16 아이폰 에뮬레이터에서 본 CNN 모바일 ∷ 그림 2-17 안드로이드 1.6 에뮬레이터에
서 본 CNN 모바일
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∷ 그림 2-18 팜 프리 에뮬레이터에서 본 ∷ 그림 2-19 오페라 미니 에뮬레이터에서 본
CNN 모바일 CNN 모바일

∷ 그림 2-20 Openwave v7 에뮬레이터에서 ∷ 그림 2-21 dotMobi 에뮬레이터에서 본
본 CNN 모바일 CNN 모바일(Nokia N70 스킨 사용)
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∷ 그림 2-22 WinWAP 에뮬레이터에서 본 CNN 모바일

표 2-3은 모바일 웹 개발에서 사용되는 모바일 에뮬레이터 리스트이다. 여러분은 모

바일 에뮬레이터의 가장 최신 리스트를 http://learnthemobileweb.com/mobile-web-

emulators/를방문에얻을수있다.

∷ 표 2-3 모바일 디바이스, 브라우저, 그리고 기반 구조(인프라) 에뮬레이터

에뮬레이터 이름 에뮬레이터 유형 URL 설명

3 3
http://developer.palm.

com/ 

SDK는 팜프리 에뮬레이터
를 포함한다.

iPhone SDK 디바이스
http://developer.apple.

com/iPhone/program/

아이폰 시뮬레이터를 포함
한다. Mac OS X에서만
구동한다.

Android SDK 디바이스
http://developer.

android.com/sdk/

SDK는 안드로이드 에뮬레
이터를 포함한다.

Windows Mobile
6 SDK

디바이스
http://msdn.microsoft.

com/enus/windowsmobile/

bb264327.aspx

SDK는 윈도우 모바일 디
바이스의 스킨과 에뮬레이
터를 포함한다.

Nokia Mobile
B r o w s e r
Simulator
4.0

브라우저

www.forum.nokia.com/info

/sw.nokia.com/id/

db2c69a2–4066-46ff-

81c4-caac8872a7c5/

NMB40_install.zip.html

노키아 디바이스에서 표시
하는 XHTML, XHTML-
MP, 그리고 WML을 보여
준다.



∷ 표 2-3 (계속)

실제 모바일 디바이스

다시말하지만, 모바일웹페이지를테스트하고확인하는가장훌륭하고확실한방법

은 실제 모바일 디바이스를 사용하는 것이다. 모바일 웹 개발자들은 개발 기간 동안

디바이스종류에의존하는기능테스트를위해다양한폰을곁에두게된다. 데스크톱

소프트웨어대신에실제배터리를사용하는모바일디바이스를사용하기때문에디바

이스종류별로테스트를하면서파이어폭스와에뮬레이터테스트에서찾을수없었던

모바일브라우저의렌더링과성능문제를찾을수있다.

만약 모바일 폰 서비스와 디바이스에 투자하는 것이 어렵다면 DeviceAnywhere

(http://deviceanywhere.com) 같은상용대체서비스를사용해네트워크로모바일디바

이스에접근할수있다. 모바일디바이스제조사와네트워크사업자들은자주개발자
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에뮬레이터 이름 에뮬레이터 유형 URL 설명

RIM Blackberry
Simulators

디바이스 기반
시설

www.blackberry.com/

developers/downloads/

simulators/index.shtml

블랙베리와 블랙베리 엔터
프라이즈 서버에 대한 시뮬
레이터이다.

Opera Mini 
Simulator

브라우저
www.opera.com/mini/

demo/ 

J2ME 또는 BREW 런타임
환경을 지원하는 일반폰에
서 고급 모바일 브라우징을
위해 Opera Mini와 프럭시
솔루션을 시뮬레이션한다.

YoSpace
SmartPhone
Emulator

디바이스
www.yospace.com/

index.php/spedemo.html

상용 디바이스 에뮬레이터
데모

Openwave Phone
Simulator V7

브라우저

http://developer.

openwave.com/dvl/

tools_and_sdk/

phone simulator/

일반폰에서 설치된 점유율
이 높은 모바일 브라우저
에뮬레이터.
XHTML과 WML을 표현
한다.

WinWAP 
Simulator

브라우저
www.winwap.com/

desktop_applications/

browser_emulator

윈도우 모바일 디바이스의
WML 모바일 브라우저를
시뮬레이션한다.  트라이얼
(trial)을 30일 동안 무료로
사용할 수 있다.



와 파트너 프로그램 회원들에게 디바이스 값을 빌려주거나 디바이스를 대여해 준다.

모바일디바이스에서모바일웹콘텐츠를테스트하는방법에대해좀더많은정보는

11장에서얻을수있다.

다른 개발 도구들

파일 비교와 소스 코드 제어 유틸리티는 모바일 웹 개발에 빠뜨릴 수 없는 유용한 도

구이다. 이 도구는 IDE에 통합돼서 사용하거나 분리된 단일 소프트웨어 제품으로도

사용가능하다.

파일 비교

파일비교유틸리티는파일을한줄단위로검사하고텍스트파일에차이를병합하는

기능을제공한다. 이유틸리티는프로젝트기간동안계속변경되는소스코드파일들

의변화를추적하는데편리하다. IDE에결합해서사용하는소스코드관리, 파일비

교도구는여러분이웹개발프로젝트에서소스코드파일의변경사항을관리하고추

적하는데도움을줄것이다.

여러분은몇가지윈도우용오픈소스파일비교유틸리티를마이크로소프트에서찾을

수 있다: WinMerge(http://winmerge.org/), ExamDiff(http://www.prestosoft.com/

edp_examdiff.asp), 그리고 WinDiff from Microsoft(http://support.microsoft.com/

kb/159214).

리눅스와유닉스운영체제에서는내장된 diff명령어를사용할수있다. 애플역시Mac

OS X를위해애플개발자도구의한부분으로무료 FileMerge 유틸리티를제공한다. 

뿐만 아니라 많이 사용되고 있는 CVS와 SVN 버전 관리 클라이언트(그림 2-23)는 파

일비교와병합유틸리티를함께묶어서제공하는도구이다. 소스관리저장소에변경

된 코드를 제출하기전에 차이점을 비교해 보고, 각 파일의 수정 내용을 다시 살펴볼

수있도록파일비교도구를사용하는것은소프트웨어개발과정에꼭필요한훌륭한

방법이다.
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∷ 그림 2-23 주석이 제거된 XHTML-MP 문서 비교(Tortoise SVN client)

소스 코드 관리

소스코드관리는프로젝트개발과정에서텍스트파일에대한수정내용을관리하고

저장하는것이다. 소스코드관리는팀원들이같은파일들을동시에작업하고하나의

복사본으로 변경 내용을 병합해 관리할 수 있도록 한다. 파일에 대한 각각의 수정 내

용은수정당사자가소유한다. 변경내용이제출되는저장장소는중앙또는분산소스

코드저장소를선택할수있다. 다수의사용자가하나의파일을수정하고제출해서충

돌이발생하면, 소스관리시스템은자동으로여러수정내용을단일변경파일에병합

하도록시도한다. 만약자동병합이수행될수없다면, 시스템은파일비교기능을사

용해사용자가직접코드변경내용들에대해수동병합을할수있도록가이드한다.
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Note 텍스트 파일 비교를 괴짜 속어로 doffing이라고 한다. diff는 초기 유닉스 파일 비교 프
로그램의 이름이다.



소스코드관리는개발기간동안소프트웨어프로젝트를제어하고안전한상태로유

지시킨다. 특히개발팀이분산돼있을때이시스템을사용하면효과가크다. 이시스

템의클라이언트서버구조는클라이언트가물리적으로어디에있든지어떤운영체제

를 사용하든지에 상관없이 소스 코드 저장소와 상호작용할 수 있다. 중앙 소스 관리

서버는소스코드파일과주석화된수정내용히스토리를저장하고사용자권한을관

리한다. 개발자들은 GUI 또는 커맨드라인 클라이언트 애플리케이션을 사용해 로컬

소스파일들을최신버전저장소로업데이트하고, 편집을위해파일을따로관리하고,

변경된파일을다시저장소로제출할수있다.개발자들은저장소에소스코드를제출

할 때 변경 내용을 설명할 수 있도록 명확하면서 의미를 제대로 전달할 수 있는 주석

을포함해야한다.

현재많이사용하면서신뢰할수있는두가지무료소스버전관리시스템에는 CVS

와 SVN이있다. 최근에는 git과 mercurial같은시스템이새로운대안으로떠오르고

있다.

CVSConcurrent Version System(http://www.nongnu.org/cvs/)는 두 시스템 중 좀 더 오래된 것

이다. 설치가쉽고널리사용되고있지만, 최근에들어서는높은브랜치태그작성비

용과 UNIX 환경에서의 서버 지원 제한, 그리고 고급 파일 관리 시나리오를 다루는

기술에서문서화된이슈들이알려지면서진부한도구라는평을받고있다.

SubversionSVN(http://subversion.tigris.org/)은 CVS를대체할수있는도구이다. 그

리고많은 CVS의단점을보안한다. SVN은서버와클라이언트사이에서플랫폼독립

적으로 사용된다. 그것은 소스 코드 관리 트랜잭션을 위해 커맨드라인 클라이언트와

Tortoise SVN(http://tortoisesvn.tigris.org/), 그리고 쉘shell과 통합된 강력하고 훌

륭한기능의윈도우 GUI 클라이언트를제공한다(그림 2-24).
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∷ 그림 2-24 추가되고, 수정되고, 그리고 관리되지 않는 파일들을 보여주는 Tortoise SVN 제출 대화
상자
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Note 여러 종류의 OS 사이에서 일관성 없이 사용되는 라인 브레이크line break 문자는 플랫폼 독
립적인 소프트웨어 개발에 난적이다. 예를 들어, 윈도우 개발자가 소스 코드를 UNIX 스타일 라인
브레이크를 갖도록 변경하고 제출한다면, 그 파일은 다시 윈도우 스타일 라인 브레이크를 포함하도
록 업데이트될 수 있다. 이것은 소스 관리 시스템이 소스 코드가 변경될 때 코드와 라인 브레이크
가 업데이트됐다는 것을 인식한 후, 그것이 파일 변경 내용들 사이의 차이를 다시 살펴볼 때 원치
않는 복잡함을 유발할 것이라는 것을 판단할 수 있기 때문이다. 만약 여러분의 프로젝트 팀원 중
다중 OS를 사용하는 개발자가 있다면 소스 코드 파일에서 라인 브레이크 형식 표준을 설정할 필요
가 있다. IDE와 테스트 편집기는 라인 브레이크 형식을 선택할 수 있는 옵션을 가지고 있으니 그것
을 사용하면 된다.



CVS와 SVN은모두서버를설치하고저장소를생성하기위해서관리자권한을가진

시스템 관리자 또는 OS 전문가를 요구한다. CVS 또는 SVN 클라이언트는 오픈소스

프로젝트로서누구나자유롭게어떤운영체제에서도쉽게설치할수있다. 또한플랫

폼독립적으로동작한다. 이것은클라이언트애플리케이션과서버가서로어떤 OS에

서동작하는지에상관없이사용할수있다는것을의미한다.

이 연습문제를 통해 여러분은 이 장에서 배운 확장 모듈을 이용해 파이어폭스로 모바일 디바이스를 위장
해서 모바일 웹을 열람할 것이다. 다음 방법을 사용해 모바일 디바이스로 위장해 보자.

■ 모바일 MIME 유형 지원

■ 모바일 마크업 형식 렌더링

■ 모바일 디바이스와 같은 HTTP 요청 헤더 전송

파이어폭스는 모바일 브라우저 또는 모바일 디바이스의 HTTP 요청 특성을 흉내 낸다. 하지만 모바일 브
라우징 행동을 복제하는 시도는 하지 않는다.

파이어폭스로 모바일 디바이스를 위장하기 위해 부록 A를 참고해서 user-agent를 사용해 보고, 부록
B를 참고해 HTTP 요청 헤더를 수정해 보자.

■ user-agent를 모바일 디바이스로 설정하기위해 User-Agent Switcher 부가 기능을 사용하라.

■ 파이어폭스 요청 헤더를 모바일 디바이스로 맞추기 위해서 Modify Headers 부가 기능을 사용
하라.

■ 요청 헤더가 부록 B의 실제 모바일 디바이스의 헤더와 일치하는지 확인하기 위해 Live HTTP
Headers 부가 기능을 사용하라.

다음은 모바일 웹에서 XHTMP-MP와 WML 문서를 열람해 보자. 서로 다른 다양한 특성을 가진 모바일
디바이스로 위장해 모바일 웹을 열람해 보자(아이폰, 팜 프리, 소니에릭슨 C905, 그리고 LG VX9100
디바이스 등).

앞의 단계를 실행한 후 다음 질문에 답하라.

1. 여러분은 같은 도메인에서 다양한 모바일 웹 경험을 할 수 있었나? 예를 들어, http://cnn.com
은 XHTML-MP와 WebKit에 최적화된 XHTML 모바일 웹사이트를 모두 제공한다.

2. 모바일 상황에서 콘텐츠는 데스크톱 웹사이트와 어떤 관련이 있었나? 데스크톱 웹과 모바일 웹
사이의 사이트의 테마는 일관성이 있었나?
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연습문제 2 파이어폭스에서 모바일 디바이스 위장하기



3. 모바일 사용자는 모바일 웹사이트를 사용할 때 목적 지향적인 패턴을 보인다. 그래서 한 사이트
에서 3분 이상 머무르는 경우가 거의 없다. 여러분은 이 시간 안에 모바일 웹사이트에서 일반적
인 작업을 끝낼 수 있었는가? (예를 들어, 날씨 웹사이트의 경우에 여러분이 사는 도시의 날씨
예보를 찾는 게 쉬었는가? 여행 웹사이트의 경우에 비행기 도착 정보를 얼마나 빨리 찾을 수 있
었나?)

4. 어떤 user-agents에 대해서 웹사이트는 모바일 최적화된 마크업으로 리다이렉트했는가? 어떤
user-agents가 데스크톱 마크업을 받았는가? 이유는 무엇인가?

이제 이 연습문제를 모바일 에뮬레이터에서 다시 수행해 보자. 파이어폭스와 에뮬레이터 사이에 모바일
웹 페이지를 표시하는 방식에서 어떤 차이가 있었는가?

요약

이 장에서 여러분은 모바일 웹 개발에서 사용하는 도구를 설치하고 설정하는 방법을

배웠다. 마크업 사용 지원과 서버 측 언어를 고려해 IDE를 선택했으며, 모바일 웹에

서흔히사용하는 MIME 유형에대해서배웠다. 추가로 MIME 유형을지원하도록웹

서버설정방법도함께배웠다. 또한모바일웹페이지가어떻게표현되는지확인하고

디버그하는세가지방법을배웠다. 파이어폭스에서부가기능을사용하는방법, 모바

일 브라우저 에뮬레이터를 사용하는 방법, 그리고 실제 모바일 디바이스를 사용하는

방법이있었다. 모바일웹소스코드관리를위해사용하는파일비교및소스버전관

리 유틸리티도 배웠다. 연습문제에서는 파이어폭스와 모바일 에뮬레이터를 사용해서

모바일디바이스로위장하고모바일웹을열람하는방법을다시되짚어봤다.

다음장에서는모바일마크업언어와스타일시트의구문을실제산업기관과표준단

체가인정한모범사례를토대로살펴볼것이다.
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